エルフレイナ終了時に「flash.ocx が必要ですが、このバージョンの Windows にはもう含まれていません」と表示される

Page updated :

The page you are currently viewing does not support the selected display language.

発生する現象

エルフレイナを終了した後に以下のような「プログラム互換性アシスタント」が表示される場合があります。

このプログラムには flash.ocx が必要ですが、このバージョンの Windows にはもう含まれていません。

発生条件

これは以下のような環境で実行したときに発生します。

  • 64 bit OS 上で実行したとき
  • ウィザードヘルプを開いたとき

原因

ウィザードヘルプは OS の実行環境に合わせて 32bit アプリケーション、または 64bit アプリケーションとして起動するか決定しています。OS が 64bit であれば、64bit アプリケーションとして起動されます。

また、ウィザードヘルプは IE のコンポーネントを使用してヘルプを表示しており、上記のように 64bit アプリケーションとして起動した場合は、IE のコンポーネントも 64bit のものを使用するようになっております。

しかし、2010/07/04 時点では 64bit 版の Flash コンポーネントは提供されていないため、上記のような警告ダイアログが表示されてしまいます。(Flash
に少しでも関連性のあるページを表示するとダイアログが表示されます)

対応策

この警告による障害は特にありません。Flash のあるページに移動した際に Flash が実行されないだけです。上記ダイアログで「このプログラムは正常に動作しました」をクリックすると次回以降エルフレイナ終了時に警告が表示されなくなります。